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1 About this user manual

This user manual contains important information in order to operate the system safely, properly 
and economically.

The user manual is intended for the owner of the system and the operating personnel.

Only few things are different between x-touchBOX and x-touchPANEL. The differences are  
indicated in this user manual.

Mounting instructions for x-touchBOX and x-touchPANEL supplement the user manual.

The following symbols are used in this user manual:

Symbol Meaning

Notes contain important information for operating the units.

- Prerequisites that must be checked prior to a certain action are marked 
with a hyphen. 

This symbol is used for instructions that consist of a single action.

1. In the case of instructions consisting of several actions, the individual 
actions are numbered.

= Results of an instruction are marked with an equal sign.

bold Buttons and terms used in the ›x-touch‹ software are marked in bold.
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2 Safety

Designated use x-touchBOX/PANEL is used for commissioning and operating DALI lighting systems. DALI is a 
standardized digital protocol for controlling lighting technology devices in accordance with the 
IEC 929 standard.

x-touchBOX can be connected to a maximum of 64 DALI operating devices. x-touchPANEL 
contains two DALI lines and can be connected to a maximum of 128 DALI operating devices.

Only operating devices equipped with a DALI interface may be connected.

Safety instructions The following safety instructions must be observed when operating the x-touchBOX/PANEL:

Every operator must read this user manual carefully and comply with the instructions contained 
therein.
The owner must ensure that the wiring instructions and  specifications for DALI lines are 
observed. 
Only one x-touchBOX may be connected to each DALI line since the bus supply is already 
integrated. Combinations with one or several x-touchPANEL in one DALI line are possible, 
however.
Touching the display with a sharp-edged object can damage the display. All display functions 
can be called up by touching the buttons. 
Only calibrate the device using the touchpanel and not via the web browser.
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3 Design and function

x-touchBOX/PANEL is an operating and control device for DALI lighting systems. The ›x-touch‹ 
software which is controlled via a colour touchscreen is integrated in the x-touchBOX/PANEL. The 
unit is designed as a box and a panel. When the unit is surface-mounted, it can be wired in a 
standard flush-mounted socket. The unit can be combined with controllers of the ›comfortDIM 
series‹. 

The ›x-touch‹ software provides the following functions:

Applications 
-  Basic for white light applications
-  Colour for RGBW applications
Configuration of 
- 16 scenes
- 99 light sequences
- 7 time-controlled schedules
- 1 calendar-controlled schedule list
Real-time clock/calendar
Configuring the buttons for manual call
Designing the buttons for manual call
Manual switching and dimming
Frame light and adjustable display light (only x-touchPANEL) 
Communication via interfaces:
- Infrared (IrDA)
- Ethernet (TCP/IP) (only x-touchPANEL)

The functions of x-touchBOX and x-touchPANEL are identical with only a few exceptions. These 
exceptions are listed in the following table (see also "Technical data", page 51).

Feature x-touchBOX x-touchPANEL

Number of DALI lines 1 2

Connection max. 64 DALI operating devices max. 128 DALI operating devices

Bus supply integrated external

Interfaces IrDA IrDA, Ethernet

Frame light — yes

Display light automatically dimmed 2 minutes 
after last activation

permanently ON or automatically 
dimmed 2 minutes after last 
activation
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3.1 DALI – Communication standard
DALI (Digital Adressable Lighting Interface) is a digital standardized protocol in acc. with IEC 929 
for flexible, room-based lighting management.

A maximum of 64 DALI operating devices can be assigned to up to 16 individually controllable 
lighting groups in one DALI line. One or several DALI lines can be connected via control devices.

DALI provides the system programmer with a set of commands that facilitates specific 
programming without special knowledge of lighting technology:

Control line polarity does not have to be observed
Standard cables can be used
Fail-safe transmission due to digital technology 

Compared with analog technology, DALI offers the following additional advantages:

Each DALI operating device can be activated individually.
DALI operating devices can be assigned to several groups simultaneously.
Scene lighting and grouping are stored in the DALI operating device.
Special settings such as the speed of colour change (fading) and net recovery behaviour are 
possible.
When individual scenes are activated, all DALI operating devices reach their dimming value 
simultaneously.
The dimming range depends on the DALI operating device and is between 0.1 and 100 %.

3.2 Software ›x-touch‹
The following explanations will help you understand the ›x-touch‹ software.

Term Meaning

Operating device DALI operating device

Group (G) The ›x-touch‹ software communicates with the operating devices (max. 
64 for each DALI line) via groups (max. 16). 
A group can be switched and dimmed individually. Groups can also 
include EM, HID, LV, INC, CONF, LED or Somfy operating devices. 

Zone (Z) Zones are only used in the Colour application. One zone consists of four 
predefined groups representing the colours red, green, blue and white. 

Scene (S) A scene serves for storing a lighting situation defined by the setting of 
one or several groups.

Sequence (SQ) Several scenes are stored in a time-specific order in a sequence.

Schedule (SDL) One or several sequences and/or scenes are stored in a time-specific 
order in a schedule. A schedule starts automatically every 24 hours at a 
preset time of day.

Schedule list (SDLL) Every schedule is assigned to one weekday. In this way, a schedule list is 
created for the calendar-controlled, uninterruptible automation of lighting 
situations.

Scheduler When Scheduler is activated, it appears in the Home menu and enables 
a sequence, schedule list and schedule to be controlled manually (Start, 
Pause, Stop and Off).

PHASED O
UT



7

Version 3.0 3.2  Software ›x-touch‹

x-touchBOX/PANEL 3  Design and function

Basic application Typical application examples for the Basic application are rooms where mostly white light is used, 
such as e.g. public rooms, production halls, restaurants and hotels.

 You can define a maximum of:

16 groups
- with up to 64 devices for x-touchBOX
- with up to 128 devices for x-touchPANEL
16 scenes
99 sequences
7 schedules
1 schedule list

The configuration of the Basic application is described in chapter "Basic application", page 19.

Colour application All colours of the RGB colour space are composed additively of the basic colours red, green and 
blue (RGB). For a better representation of white light, an additional white light source is used 
(RGBW colour mixing).  

The colour control of a lighting system is performed in the Colour application. The Colour 
application is different from the standard Basic application with respect to the grouping of the 
operating devices.

In the ›x-touch‹ software, each RGB/RGBW operating device is assigned to a colour scale (red, 
green, blue, white) of a zone. Four zones with 4 colour scales are available. The colour scale of a 
zone corresponds to a group. In the Home menu, the white light can be switched and dimmed via 
groups 1 to 4.

The table shows the assignment of the 16 groups to the four colours of the individual zones. Zone 
assignment is automatically controlled by the software.

Typical application examples for the Colour application are rooms where mainly RGBW operating 
devices are used to implement freely designed colour changes and colour effects, e.g. in shop 
windows, bars and exhibition spaces. 

 You can define a maximum of:

4 zones with the 4 colours red, green, blue and white
- with up to 64 devices for x-touchBOX
- with up to 128 devices for x-touchPANEL
16 scenes for white light
8 colour scenes
99 sequences
7 schedules
1 schedule list

The configuration of the Colour application is described in chapter "Colour application", page 30.

W R G B

Z1 1 5 6 7

Z2 2 8 9 10

Z3 3 11 12 13

Z4 4 14 15 16
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3.3 Navigation
When you navigate through the ›x-touch‹ software, you are guided through menus that are called 
up by pressing symbols and buttons. Certain functions - e.g. grouping - can be operated using 
Drag & Drop, i.e. a symbol can be touched and moved to the intended position on the 
touchscreen.

The symbols have the following meanings:

 Home In the Home menu, lighting situations can be called up manually (see also "Operation in the Home 
menu", page 34). The number and selection of lighting situations are configured depending on the 
application. The buttons of the lighting situations can be designed as desired, e.g. with pictograms 
or specific names (see "Configuring buttons in the Home menu", page 37).

The following actions are possible in the Home menu:

Switching a scene on and off
Dimming group/s or all operating devices up or down
Switching a group on and off
Dimming a group up and down
Starting, interrupting and ending a sequence, schedule or schedule list
Deactivating the touchscreen for cleaning

1. Press the Home button. 

2. Press the arrow keys as often as necessary until the desired lighting situation is displayed (e.g. 
scene).

3. Press the button to call up the lighting situation (e.g. scene).

4. Press the arrow keys to dim the operating devices up or down.

5. Press the OFF button to switch the lighting situation off.

Button Function

Opens the Home menu.

Opens the Main Menu.

Opens the Time & Date dialog box.

Displayed when a function is active (e.g. called up sequence).
Opens the page where the function is started/stopped.

 
Opens the following or previous page in a menu.
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 Main Menu In the Main Menu, basic software settings are configured, lighting situations are defined and time 
sequences are specified. The Main Menu is different in the Basic and Colour applications. 

1. Press the Main Menu button. 
2. Press the button for the desired submenu.

Button Function

Schedule list (SDLL) Opens the page where you can assign schedules to certain 
weekdays.

Schedule (SDL) Opens the page where you can define schedules.

Sequence (SQ) Opens the page where you can assign sequences to the timeline and 
determine fade times.

Scenes (S) Opens the page where you can assign the corresponding groups to a 
scene.

Addressing/grouping Opens the page where you can select the addressing method, 
address the devices and group them in groups or zones.

Configuration Opens the page where you can configure the software and 
communicate via interfaces.
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4 Basic settings

The following table shows the basic settings that can be made in the tabs of the Configuration 
menu.

Tab Entry Function

Display Language Setting the ›x-touch‹ software language.

Clean Briefly locking the touchscreens for cleaning.

Calibrate Centering the screen surface and touchscreen.

Contrast Reducing or increasing the screen surface 
contrast.

Beep on touch Activating or deactivating beep on touch.

Lock configuration Locking or releasing the user interface in the 
Home menu (password-protected).

Screen-saver Activating or deactivating the screen saver.

Lock panel Locking or releasing the touchscreen (password-
protected).

System Program version Indicates the ›x-touch‹ software version.

Display name Enter name for x-touchBOX/PANEL (for 
identification when several devices are used).

Reset to factory 
defaults

Resetting the values to the factory default values, 
e.g. Layout, Names.

Action at net recovery Controlling the behaviour after a power supply 
interruption.

Application Selecting the Basic or Colour application.

Names Sequences, Edit Assigning application-specific names to 
sequences 1 to 99.

Scenes, Edit Assigning application-specific names to scenes 1 
to 16.

Groups, Edit Assigning application-specific names to groups 1 
to 16.

Schedules, Edit Assigning application-specific names to 
schedules 1 to 7.

Customized buttons Using application-specific graphics for buttons in 
the Home menu.
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Layout S1...S4, S5...S8, 
S9...S12, S13...S16

Selecting buttons for the Home menu (4 scenes 
on each page).

Dim Activating the dimming function for buttons 
activated in the first column.

S1...S8, S9...S16
(Colour application : 
2 zones, 4 zones, 
colour scenes)

Selecting buttons for the Home menu (8 scenes 
on each page, in the Colour application 2 zones, 4 
zones or 8 colour scenes).

Scheduler Activating the Scheduler.
Scheduler enables controlling the sequence, 
schedule list and schedule manually (Start, Pause, 
Stop and Off).

G1...G4, G5...G8, 
G9...G12, G13...G16
(Colour application : 
G1...G4)

Selecting buttons for the Home menu (4 groups 
on each page). 
Only the 4 groups White are possible in the 
Colour application.

Cleaning Selecting buttons Clean, OFF and ON for the 
Home menu. Clean deactivates the touchscreen 
for 20 seconds during cleaning. The OFF and ON 
buttons are used for switching configured lighting 
situations.

IrDA Infrared devices  Field that displays the IrDA device that 
communicates with x-touchBOX/PANEL.

Reset Repeat establishing the connection.

Send Starting transmission.

Status Shows the transmission status.

Enable discovery Activating or deactivating device identification.

Enable file reception Activating or deactivating file reception.

TCP/IP MAC Shows the MAC address of the x-touchPANEL.

IP Picker Entering the IP address (for Ethernet connection).

Subnet Mask Entering the subnet mask (for Ethernet 
connection).

Gateway Entering the gateway (for Ethernet connection).

Status Shows the connection status.

Tab Entry Function
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4.1 Opening the Configuration menu
1. Press the Main Menu symbol.
2. Press the Configuration button.

= The Configuration window with the Display tab is displayed.

 

 
3. Press the green arrow key to call up the following tab.

4.2 Selecting the language
The language of the software interface is selected in the Display tab.

– The Main Menu is open.

1. Press the Configuration button.
= The Configuration window with the Display tab is displayed.

2. Press the arrow key next to Language.
= The list of available languages is displayed.

3. Press the language you wish to select.
= The software interface is now displayed in the selected language.
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4.3 Behaviour at net recovery
In the Configuration menu you can define how the system will behave after a power failure. 

– The System tab is open in the Configuration menu.

1. Press the Action at net recovery button. 
= The dialog box Action at net recovery is displayed.

2. Activate the desired check box and confirm with OK.

4.4 Determining the display name and program version

– The Main Menu is displayed.

1. Press the Configuration button.
2. Press the System tab.

= The display name and Program version are displayed.
3. Press the display name to change it.

= The dialog box Keyboard is displayed.

4. Enter the new name and confirm with the Enter key.

5. Press the Esc button to abort the process.

Function Action at net recovery

No action No commands are transmitted.

Broadcast OFF All operating devices are switched off.

Broadcast MAX All operating devices are set to maximum luminous intensity. Somfy 
components are started.

Broadcast MIN All dimmed operating devices are set to the stored dimming value and all 
other devices are set to maximum luminous intensity. Somfy components 
are shut down.

Scheduler start The Scheduler is started. A sequence is restarted, schedule and schedule 
list are continued.

Hint

If an Ethernet connection is established you can use the keyboard of your PC or laptop.
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4.5 Setting the time and date
In order for the functions of time-controlled actions and for the frame light to work, the time and 
date must be set.

1. In the Main Menu, press the Time & Date symbol.
= The dialog box Time & Date is displayed.

2. Set the time and date with the arrow keys and confirm with OK .

4.6 Adjusting the touchscreen
In the Display tab, the user interface can be adjusted to suit your requirements. 

– The Display tab is open in the Configuration menu.

To modify the contrast, press the - -  or + + buttons.

To activate a confirmation sound that is generated whenever a button is pressed, activate the 
Beep on touch check box. 
To switch on the screen saver, activate the Screen saver check box. 
= When the screen saver is activated, it appears two minutes after the touchscreen has been 
touched last.
To center the touchscreen, press the Calibrate button on the touchscreen and follow the 
instructions. Only carry out this function on the touchscreen and not via the web browser.

Hint

In the case of a power failure, a back-up battery supplies the clock for at least 24 hours. If no 
voltage is supplied to the x-touchBOX/PANEL for a longer period of time, the date and time must 
be set again.

Hint

It is possible to load an application-specific screen saver (see "Loading application-specific 
buttons and screen saver", page 40).
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4.7 Setting the frame light and display light
Setting of frame light and display light is only possible in conjunction with x-touchPANEL x-
touchBOX lacks frame light and the display light is set at the factory and cannot be modified.

The frame light is controlled in two intervals. Therefore, you can assign one colour for each interval 
to the frame light or switch it off for one interval (e.g. night service). Select the colour in the dialog 
box Framelight.

If you do not activate the screen saver, TridonicAtco recommends using the display light Dimmed 
automatically for x-touchPANEL, since this will prevent an image persistence.

– Time and date are set.

– The Display tab is open in the Configuration menu.

1. Press the Framelight button in order to change the frame light or display light.
= The dialog box Framelight & display light is displayed.

2. To set the two starting times for the frame light, set the times with the arrow keys.
3. To set the frame light colour, press the colour field and select the desired colour or enter the 

colour using the RGB values and confirm with OK.
- or -
To switch off the frame light, press ›Black‹ or enter the RGB values 0/0/0 and confirm with OK.
= The frame light is displayed in the selected colour or goes out.

4. Press the arrow key to set the display light.
= The selection window is displayed.

5. To dim down the display light 2 minutes after the device has been operated last, activate 
Dimmed automatically. 
- or -
To maintain the display light, activate Always ON. 
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4.8 Assigning names
To facilitate configurations and operating steps for later operation, you can assign application-
specific names to Scenes, Sequences, Groups and Schedules.

 Names are assigned in the same way for scenes, sequences, groups and schedules.

– The Names tab is open in the Configuration menu.

1. Press an arrow key below the entries Sequences, Scenes, Groups or Schedules.
= The selection window is displayed.

2. Select the lighting situation and press the Edit button next to it.
= The dialog box Keyboard is displayed.

3. Enter the new name and confirm with the Enter key.

4. Press the Esc button to abort the process.

Hint

If an Ethernet connection is established, you can use the keyboard of your PC for entering the 
names to be assigned with x-touchPANEL (see "Ethernet interface", page 44).

Hint

If you activate the check box Customized buttons, application-specific graphics are assigned to 
the buttons of the Home menu, irrespective of the assigned names. The graphics can contain 
symbols or other fonts (see "Loading application-specific buttons and screen saver", page 40).
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4.9 Password protection

If you assign a password, you can limit the access in two stages.

Lock configuration:
The Home menu can be freely accessed for operation. Configuration of the buttons and the 
Main Menu are password-protected.
Lock panel
The entire touchscreen is password-protected.

4.9.1 Locking the configuration

– The Display tab is open in the Configuration menu.

1. Activate the Lock configuration check box.
= The password-protection is now set (factory setting ›1234‹). A dialog box is displayed where 
you can change the password.

2. To change the password, press Yes and enter the old password in the dialog box. Enter the 
new password in the following two dialog boxes and confirm with OK.

3. To modify the password, press No. 
4. Press the Home menu to activate password protection.

= The Main Menu can only be called up after entering the password. 

4.9.2 Locking the panel

– The Display tab is displayed in the Configuration menu.

1. To lock operation of the entire touchscreen, activate the check boxes Screen-saver and Lock 
panel.
= The password-protection is now set (factory setting ›5678‹). A dialog box is displayed where 
you can change the password.

2. To change the password, press Yes and enter the old password in the dialog box. Enter the 
new password in the following two dialog boxes and confirm with OK.

3. To modify the password, press No. 
= When the screen saver appears, the touchpanel can only be operated after entering the 
password. 

Hint

Make sure that you open the Home menu after you have locked the configuration. Only then will 
the password protection take effect.

Hint

Make sure that the screen saver appears after you have locked the entire touchscreen. Only then 
will the password protection take effect.
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4.10 Cleaning the touchscreen
In order to clean the touchscreen without accidentally changing settings, the touchscreen can be 
temporarily deactivated.

– The Display tab is displayed in the Configuration menu.

1. Press the Clean button.
= The touchscreen is deactivated for 20 seconds. The remaining time is indicated.

2. Clean the touchscreen with a soft, damp cloth.

Hint

If you activate the Clean check box in the Display tab of the Configuration menu, a button is 
displayed in the Home menu which also deactivates the touchscreen for cleaning. Cleaning is then 
also possible without a entering password if the configuration is locked.
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5 Basic application 

This chapter contains the following topics:

Addressing and grouping
Scenes (S)
Sequences (SQ)
Schedules (SDL)
Schedule list (SDLL)

5.1 Addressing and grouping
To enable communication of x-touchBOX/PANEL with the operating devices, every operating 
device of the system must be individually addressed and assigned to a group. Addressing is 
performed automatically, grouping must be done manually. 

For the subsequent operating devices, the address number is supplemented with the specific 
abbreviation. Identification of the components is only displayed if this is supported by the units.

EM
HID
LV
INC
CONF
LED
Somfy

The dialog box Addressing method provides two ways of addressing:

System extension
Only newly added operating devices are addressed. The existing addresses remain 
unchanged.
Reinitialization
All operating devices of the system are re-addressed. The existing addresses are overwritten.

After automatic addressing, the addresses (1 to 64/128) and, if applicable, specific operating 
devices are indicated (e.g. HDI). 

Hint

In order to facilitate programming and operating steps, you can assign names to groups, scenes, 
sequences and schedules (see "Assigning names", page 16).
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The following operating elements are available for grouping.

If the Groups are displayed in the Home menu, the dimming function is replaced by moving the 
blinds if there is an integrated blinds controller (Somfy). This is indicated as follows:

Element Meaning/Function

The group number (G1) is set at the factory, the group name (Group 
1) can be assigned as desired.

Use the arrow keys to select the operating device that you want to 
assign to a group.

Use this button to remove the selected device from the group.

The Folder button opens the dialog box Load group. 

 
The Save button opens the dialog box Save as group. You select a 
group to save the current settings.

Hint

If an operating device is assigned to several groups, the value of the higher group number is 
saved.
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5.1.1 Addressing and grouping operating devices

For x-touchBOX, 64 device addresses are available, for x-touchPANEL, addresses 1-64 are 
assigned for DALI line 1, and addresses 65-128 are assigned for DALI line 2. 

– The Main Menu is open.

1. Press the Addressing/grouping button.
= The dialog box Addressing method is displayed.

2. Activate the check box System extension or Reinitialization.
3. Press the Continue > button.

= The ›x-touch‹ software searches for connected operating devices and indicates the number 
of devices it has detected.

4. When the message Search completed is displayed, press the Complete button.
= Every device is addressed.

The Addressing of G ... page is displayed.
5. Press the Folder button to select the group in which the operating devices are to be stored.

= The dialog box Load group is displayed.
6. Select the group with the arrow keys and confirm with OK. 

= The group is indicated.

 

7. Select the address of the operating unit using the arrow keys.
8. Move the address of the operating device (1) to the group field using Drag & Drop.

= The device address is displayed in the group field of the currently selected group.

 

9. Select further addresses using the arrow keys and drag them to the same group field.

10.Press the Save button.
= The dialog box Save as group is displayed. 

11.If necessary, change the group in which the operating devices are to be stored and confirm 
with OK.
= The group is stored.

12.Repeat steps 5-11 until every operating device is assigned to a group.

Hint

Use Drag & Drop to group the operating devices, i.e. touch the device address and drag the 
symbol over the touchscreen to the group field.
When the device address is touched, the corresponding operating device will react. 

Hint

TridonicAtco recommends storing Somfy operating devices in separate groups, i.e. separately 
from other operating devices.

Hint

Grouping is not stored until you press the Save button and confirm with OK in the dialog box.
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5.2 Scene
One or several groups are stored in a scene. The groups are dimmed, masked or switched off in 
such a way that a lighting situation is created which meets the requirements. Up to 16 scenes with 
up to 16 groups can be stored in one scene.

To set a scene, the following operating elements are used:

Element Meaning/Function

The scene number (S1) is set at the factory, the scene name (Scene 1) can 
be assigned as desired.

A scroll bar shows the setting of the dimming value.
Use the arrow keys or the black field on the scroll bar to change the 
dimming value. The dimming value appears below the scroll bar in percent 
(51).

If a group is occupied by Somfy components, the OPEN and CLOSE 
buttons are displayed in this group.
Use these buttons to open or close the blinds.

If the Mask button is activated, the settings for this group are maintained 
independent of this scene. 

If the OFF button is activated, the group is switched off in the scene.

Press the Folder button to open the dialog box Load scene.

Press the Save button to open the dialog box Save scene. The group 
settings are stored in the desired scene.

Use the green arrow key to go to the next page.
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5.2.1 Configuring scenes

In a scene, one of the following settings is made for each group:

Dim
- or -
Off
- or -
Mask

– One or several groups are defined.

– The Main Menu is displayed.

1. Press the Scene button.
= The S...: page is displayed.

2. Press the Folder button to select the scene in which setting of the groups is to be saved.
= The dialog box Load scene is displayed.

3. Use the arrow keys to select the scene (S1 to S16) and confirm with OK. 
= The scene is displayed.

4. Press the arrow keys of the scroll bar until the desired value is reached to set the dimming 
value for the first group.
- or -
Press the Mask button so that the settings of the scene do not influence the first group.
- or -
Press the OFF button to switch off the first group.

5. Repeat steps 3 to 4 for the three remaining groups.
6. Press the Save button.

= The dialog box Save as scene is displayed. 
7. If necessary, change the scene in which the groups are to be saved and confirm with OK.

= The scene is saved.
8. To define further groups for this scene, press the green arrow key and repeat steps 3 to 6 on 

the following two pages.
9. To define additional scenes, press the Folder button and select a new scene using the arrow 

keys. Repeat steps 2 to 7 if necessary. 

Hint

To configure a scene, one operating device must only be assigned to one group, because 
otherwise conflicts might occur.

Hint

A scene is not saved until you press the Save button and confirm the dialog box Save as scene 
with OK.
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5.3 Sequence
Start, duration and repetition of scenes are saved in a defined order in a sequence. You can assign 
scenes to a sequence several times and in any order.

A sequence is ended if: 

Schedule list, schedule or another sequence is called up.
The sequence is ended manually.
The end of the sequence is reached.

To define a sequence, the following operating elements are available: 

Hint

A scene will only achieve its final dimming level within a sequence if no other sequence is called up 
during the fade time.

Element Meaning/Function

The sequence number (SQ1) is set at the factory, the name (Sequence 1) 
can be assigned as desired. 

Use the arrow keys to select the scene you want to include in the 
timeline.

Use this button to remove the selected scene from the sequence.

The timeline visualizes:
- The duration of a sequence (max. 23:59:59)
- The start of a scene
- The intervals between scenes
- The end of a scene

Use the arrow keys to move the visible section of the timeline.

Use the magnifier to scale the timeline section up or down. 

Press the Folder button to open the dialog box Load sequence.

 
Press the Save button to open the dialog box Save sequence. The 
current settings are saved in the desired sequence.

Press the Timeline button to set the duration and the number of 
repetitions of a sequence.
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5.3.1 Configuring sequences

In a sequence, scenes are saved at a defined position on a timeline. The number of repetitions is 
determined with the digits 2 to 6 and Loop. If you enter 1, the sequence is only called up once. If 
you enter 2, it is called up twice, and so on. Loop means that the sequence will be permanently 
repeated. 

– One or several scenes are defined.

– The Main Menu is displayed.

1. Press the Sequence button.
= The SQ... Page is displayed.

2. Press the Folder button to select the sequence in which the scenes are to be stored.
= The dialog box Select sequence is displayed.

3. Use the arrow keys to select the sequence (SQ1 to SQ99) and confirm with OK. 
= The sequence is indicated.

4. Press the Timeline button to enter the duration of the sequence.
= The dialog box Timeline is displayed.

5. Press the arrow keys of the Duration field until the desired period is set.
- or -
Press the numbers in the number field. Select the duration in the dialog box Time entry and 
confirm with OK.

6. Press the arrow keys in the Loop field until the correct number of repetitions is set.
7. Confirm the entries with OK.
8. With the arrow keys and the magnifier, adjust the timeline section in such a way that the 

starting time for the scene is visible.

9. Use the arrow keys to select the marker Scene (S1-S16).

10.Move the marker Scene to the desired position on the timeline using Drag & Drop.
11.Repeat steps 8 to 10 to enter further scenes.

12.Press the Save button.
= The dialog box Save sequence is displayed. 

13.If necessary, change the sequence in which the scenes are to be saved and confirm with OK.
= The sequence is saved with the current settings.

14.To define additional sequences, repeat steps 2 to 13. 

Hint

A sequence is not saved until you press the Save button and confirm the dialog box Save 
sequence with OK.PHASED O
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5.3.2 Setting the exact starting and fade time of a scene

After you have moved the scenes to the timeline you can set the exact starting and fade times for 
the individual scenes.

– One or several scenes are stored in a sequence.

1. Touch the marker Scene on the timeline until the dialog box Details for scene is displayed.

=
2. Press the arrow keys on the first 3 fields Time (hh:mm:ss) until the desired starting time is set.
3. Check that in the 4th field Scene the scene is set for which this is to be the starting time. Press 

the arrow keys as often as necessary until the desired scene is displayed.
4. In the 5th field Fading press the arrow keys until the desired fade time (0 to 90 s) is displayed.
5. Confirm the settings with OK.
6. Press the Save button.

= The dialog box Save sequence is displayed. 
7. If necessary, change the sequence in which the scenes are to be saved and confirm with OK.

= The sequence is saved.
8. To set the exact starting or fade time of scenes for further sequences, repeat steps 1 to 7.
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5.4 Schedule (SDL)
A schedule comprises the time between 0:00:00 and 23:59:59. A schedule is a defined sequence 
of scenes and sequences. A schedule can be started manually or it can start automatically within 
an activated schedule list. x-touchBOX/PANEL can save up to 7 schedules, i.e. no more than one 
schedule for each weekday.

Depending on the application, you can use scenes and sequences several times and in any order 
in a schedule. The duration of the sequences is visualized by the marker flags on the timeline. 

To define a schedule, the following operating elements are available:

Element Meaning/Function

The schedule number (SDL1) is set at the factory, the name 
(Schedule 1) can be assigned as desired. 

Use the arrow keys to select the sequences and scenes you want to 
include in the timeline. After S16 the marker Off is displayed. The 
marker Off ends a scene, sequence or schedule and can be set 
several times.

Use this button to remove the selected scene or sequence from the 
schedule.

The timeline visualizes:
- The complete schedule (0:00 to 23:59 )
- The start of a scene/sequence
- The duration of a scene/sequence
- The end of a scene/sequence
- The intervals between scenes/sequences

 

Use the arrow keys to move the visible section of the timeline.

Use the magnifier to scale the timeline section up or down. 

The Folder button opens the dialog box Load schedule.

The Save button opens the dialog box Save schedule. The current 
settings are saved in the desired schedule.

Hint

If a Sequence, Schedule or Schedule list is started in the Scheduler, the currently enabled function 
(Sequence, Schedule, Schedule list) is terminated.
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5.4.1 Configuring schedules

A schedule is defined by the order of scenes and sequences on the timeline.

– Time and date are set.

– Scenes and/or sequences are defined.

– The Main Menu is displayed.

1. Press the Schedule (SDL) button.
= The SDL ... window is displayed.

2. Press the Folder button to select the schedule in which the scenes/sequences are to be 
saved.
= The dialog box Load is displayed.

3. Select the schedule with the arrow keys and confirm with OK. 
= The schedule is displayed.

4. Use the arrow keys to select the marker Scene or Sequence.

 
5. Move the marker scene or sequence to the desired position on the timeline using Drag & Drop.
6. To enter additional scenes or sequences, repeat steps 4 and 5.

7. Press the Save button.
= The dialog box Save is displayed.

8. If necessary, change the schedule in which the scenes/sequences are to be saved and confirm 
with OK.
= The schedule is displayed.

9. To define additional schedules, repeat steps 2 to 8. 

5.4.2 Loading or checking a schedule

– Time and date are set.

– Scenes and/or sequences are defined.

– The Main Menu is displayed.

1. Press the Schedule (SDL)  button.
= The SDL ... window is displayed.

2. Press the Folder button.
= The dialog box Load schedule is displayed.

3. Select the schedule with the arrow keys and confirm with OK .
= The schedule is displayed on the timeline.

4. Change and save the schedule as required.

Hint

A schedule is not saved until you press the Save button and confirm the dialog box Save 
schedule with OK.

Hint

The exact starting time of a sequence is set in the same way as for a scene (see "Setting the exact 
starting and fade time of a scene", page 26).
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5.5 Configuring a schedule list
Assign the schedules you have defined to the days of the week to create an uninterrupted 
schedule list. In the factory setting, the first schedule is assigned to all weekdays.

– One or several schedules are defined.

– The Main Menu is displayed.

1. Press the Schedule list (SDLL) button.

=
2. Press the black arrow key.

= The selection window is displayed showing SDL1 to SDL7 and Off.
3. Select the required schedule.

- or -
 Select Off.

4. Repeat steps 2 to 5 for each weekday.
= The schedule list is now saved without confirmation.

Hint

A schedule list is started, ended or interrupted in the Home menu (see "Manually switching a 
sequence, schedule or schedule list", page 41).
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6 Colour application 

This chapter only explains the operating steps that are different from the Basic application.

It contains the following topics:

Changing the application to Colour
Addressing and zone assignment
Colour sequences

The following topics are performed identically in both applications. They are explained at the points 
indicated.

Configuring scenes (see "Configuring scenes", page 23).
Configuring schedules (see "Schedule (SDL)", page 27).
Configuring a schedule list (see "Configuring a schedule list", page 29).

6.1 Changing the application
When the application is changed, the ›x-touch‹ software is automatically restarted. 

– The System window is open in the Configuration menu.

1. Press the Application button.
= The dialog box Application is displayed.

2. Press the arrow key. 
= The BASIC/COLOUR selection window is displayed.

3. Press the COLOUR button and confirm with OK.
4. Confirm the security enquiry with OK.

= After restarting, the Colour application is set.

6.2 Addressing and zone assignment

Addressing Addressing of the operating devices is performed in the same way in the Colour and Basic 
applications (see "Addressing and grouping", page 19). 

Zone assignment In the ›x-touch‹ software, each RGB/RGBW operating device is assigned to a colour scale (red, 
green, blue, white) of a zone using Drag & Drop. Four zones with 4 colour scales are available. 
Each colour scale of a zone corresponds to a group.

Hint

If you want to change to the Basic application, proceed in the same way.
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Since the three groups Red, Green and Blue are necessary for colour mixing and only the group 
White is not required, only the groups White (max. 4 groups) can be controlled individually. For 
basic lighting, e.g., the group White of the four zones is used. 

The groups White can be dimmed, masked or switched off and saved in scenes in analogy to the 
Basic application. Depending on the configuration, the groups can be switched and dimmed 
individually using the Home menu(see "Creating a layout for the Home menu", page 36).

6.2.1 Addressing RGBW operating devices and assigning them to zones

Refer to chapter "Addressing and grouping", page 19 for a description of the procedure and the 
addressing methods System extension and Reinitialization.

– The Main Menu is displayed.

1. Press the Addressing/grouping button.
= The dialog box Addressing method is displayed.

2. Activate the check box System extension or Reinitialization.
3. Press the Continue > button.

= The ›x-touch‹ software indicates the number of the operating devices it has detected.
4. When the message Search completed is displayed, press the Complete button.

= Every operating device is addressed.
The Addressing of Z ... window is displayed.

5. Press the Folder button to select the zone in which the operating devices are to be saved.
= The dialog box Select zone is displayed.

6. Set the zone with the arrow keys and confirm with OK . 
= The zone is displayed.

 

7. Use the arrow keys to select the operating device address to be assigned to the zone.

8. Move the address of the operating device (1) to the group field representing the respective 
colour via Drag & Drop.
= The address is displayed in the group field of the currently selected zone.

9. Repeat steps 8 and 9 until the operating devices of this zone are assigned to one of the four 
group fields.

10.Press the Save button.
= The dialog box Save zone is displayed.

11.If necessary, change the zone in which the operating devices are to be stored and confirm with 
OK.
= The zone is stored.

12.Repeat steps 5 to 12 until every operating device is assigned to a zone.

Hint

Zone assignment is not stored until you press the Save button and confirm with OK in the dialog 
box.

PHASED O
UT



6.3  Configuring colour sequences Version 3.0

32

6  Colour application x-touchBOX/PANEL

6.3 Configuring colour sequences
In a colour sequence, scenes (white light) and colour events (RGB(W)) are saved at a defined 
position on a timeline. How often the colour sequence will be repeated is determined with the 
digits 2 to 6 and Loop. If you enter 1, the sequence is only called up once. If you enter 2, it is 
called up twice, and so on. Loop means that the colour sequence will be permanently repeated.

Only after a colour event has been assigned to a colour sequence can the event be configured.

A colour sequence is ended if: 

Another colour sequence/scene is called up.
The colour sequence is ended manually.
The end of the colour sequence is reached.

– The Main Menu is displayed.

1. Press the Colour sequence (SQ) button.
= The SQ … window is displayed.

2. Press the Folder button to select the colour sequence in which the scenes are to be stored.
= The dialog box Load sequence is displayed.

3. Select the colour sequence with the arrow keys and confirm with OK.
= The sequence is indicated.

4. Press the Timeline button to enter the Duration of the colour sequence.
= The dialog box Timeline is displayed.

5. Press the arrow keys of the Duration field until the desired period is set.
- or -
Press the numbers in the number field. Select the duration in the dialog box Time entry and 
confirm with OK.

6. Press the arrow keys in the Loop field until the correct number of repetitions is set.
7. Confirm the entries with OK.
8. With the arrow keys and the magnifier, adjust the timeline section in such a way that the 

starting time for the colour event is visible.

9. Move the marker Colour event to the desired position on the timeline using Drag & Drop.
= The start for the Colour event marker is specified. 

10.Repeat steps 6 to 9 to enter further colour events.
11.Press the Save button.

= The dialog box Save sequence is displayed. 
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12.If necessary, change the colour sequence in which the colour events are to be stored and 
confirm with OK.
= The colour sequence is saved with the current settings.

13.To define additional colour sequences, repeat steps 2 to 12. 

6.4 Configuring colour events
This chapter explains how to configure the exact starting time, fade time and colour for the colour 
event. You can select the colour in a colour table or enter the individual values for the RGBW 
colours (red, green, blue, white) numerically.

– The Main Menu is displayed.

1. Press the Colour sequence (SQ) button.
2. Touch the marker Colour event on the timeline until the dialog box Details for colour event is 

displayed. 
= The dialog box Details for colour event is displayed.

3. To determine the RGB value using a colour table, press a colour in the first RGB tab.
- or -
To enter the RGB value numerically, enter the RGB values in the second tab.
- or -
To enter the RGBW values numerically, enter the RGBW values in the third tab.

4. Activate the Zones check box (Z1 to Z4) to assign the colour event to one or several zones. 

5. To define the exact duration and fade time, press the Timing, Fading button. Set the values 
with the arrow keys and confirm with OK .

6. Confirm the entries with OK.
7. To define additional colour events, repeat steps 2 to 6.
8. Confirm the settings with OK.

= The colour event is stored in the colour sequence.
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7 Operation in the Home menu

In the Home menu, lighting situations are called up manually using freely configurable buttons.

7.1 Overview
The number of pages in the Home menu depends on the application (see "Configuring buttons in 
the Home menu", page 37) and the settings in the Configuration menu (see "Creating a layout for 
the Home menu", page 36). 

All buttons of the Home menu that can be activated are described in the following chapter. The 
Scheduler is described in chapter "Manually switching a sequence, schedule or schedule list", 
page 41.

Basic application Switching a maximum of 4 pages with 4 scenes on and off and dimming them.
Switching a maximum of 2 pages with 8 scenes.
Switching a maximum of 4 pages with 4 groups on and off and dimming them.

1 Page with the ON, OFF and Clean buttons.
1 Page with the selection window and the Scheduler and OFF buttons.

Hint

The following rules apply for operation with the Home menu:

If an action is called up manually, this is independent from time-controlled lighting situations.
Manually calling up a scene/group interrupts a sequence or a schedule only until the following 
scene of the sequence or the following scene or sequence of the schedule starts.
If a schedule/sequence is called up manually, a currently active schedule/sequence is ended. 
The manually called up function is active until it is manually switched off or until it ends.
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Colour application Switching and dimming a maximum of 4 pages with 4 scenes. 
1 Page with 8 colour effects for 4 zones for each colour scene.

1 Page with 2 colour effects for a maximum of 4 zones for each colour effect.
1 Page with 4 colour effects for a maximum of 4 zones for each colour effect.
Switching a maximum of 1 page with 4 groups on and off and dimming them (group White in 
each of the 4 zones).

1 Page with the ON, OFF and Clean buttons.
1 Page with the selection window and the Scheduler and OFF buttons.

PHASED O
UT



7.2  Creating a layout for the Home menu Version 3.0

36

7  Operation in the Home menu x-touchBOX/PANEL

7.2 Creating a layout for the Home menu 
The Home menu is configured in such a way that only the buttons you want to appear are 
displayed. Activate the buttons in the Layout tab. All buttons are activated at the factory. 

In addition, you can change the factory-set functions of the buttons (see "Configuring buttons in 
the Home menu", page 37) and protect the configurations with a password if required 
(see "Password protection", page 17).

Use the Dim function to activate the dimming function for the buttons in the first column. 

Use the Scheduler function to start and stop time-controlled actions manually in the Home menu. 

The Cleaning button deactivates the touchscreen for 20 seconds. The ON and OFF buttons can 
be configured and, e.g., switch all operating devices on or off, or a frequently used lighting 
situation such as cleaning or night lighting is assigned to them (see "Configuring buttons in the 
Home menu", page 37).

– The Layout tab is open in the Configuration menu.

Activate the check boxes for the functions you want to be displayed as buttons in the Home 
menu.
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7.3 Configuring buttons in the Home menu
The following table lists the optional button configurations depending on the application. The Dim 
buttons can be configured in the Basic application. In the Colour application, it is only possible to 
dim the white light (group 1 to 4).

Button/

Option in the Basic application

Button/

Option in the Colour application

Scene

No function
Default (factory setting)
Special: 
- SDL1 to SDL6 
- SQ1 to SQ6
- Schedule list
- Stop

Scene

No function
Default (factory setting)
Special: 
- SDL1 to SDL6
- SQ1 to SQ6
- Schedule list
- Stop

— Zone

1 colour for 1 to 4 zones

— Colour scene

4 zones (1 colour for each zone)

OFF (on Cleaning page)

No function
Broadcast OFF (switch off all operating 
devices)
Group OFF
- G1 to G16

OFF (on Cleaning page)

No function
Broadcast OFF (switch off all operating 
devices)
Zone OFF
- Zone 1 to 4 

ON (on Cleaning page)

No function
Broadcast 100% (switch on all operating 
devices) 
Group 100%
- G1 to G16

ON (on Cleaning page)

No function
Broadcast 100% (switch on all operating 
devices) 
Zone 100%
- Zone 1 to 4 

OFF (on Scene, Group, Scheduler page)

No function
Broadcast OFF (switch off all operating 
devices)
Group OFF
- G1 to G16

OFF (on Scene, Zone, Colour scene, Group, 
Scheduler page)

No function
Broadcast OFF (switch off all operating 
devices)
Zone OFF
- Zone 1 to 4

Hint

In the Home menu, the buttons are displayed with the names you have assigned to them in the 
Names tab of the Configuration menu. 
It is also possible to assign an application-specific graphic to the buttons (see "Loading 
application-specific buttons and screen saver", page 40).
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7.3.1 Configuring the Scene button

– Sequences or schedules are defined.

– Layout for Home menu has been created.

– The Home menu is displayed.

1. To assign a new function to a button press the button (e.g. Scene1) until the dialog box 
Config. button  is displayed. 

=
2. To remove the function from the button, activate the check box No function.

- or -
To assign the factory setting to the button, activate the check box Default.
- or -
To assign a lighting situation to the button, activate the check box Special and activate then 
the check box Schedule list SDLL, Schedule SDL, Sequence SQ or Stop.

3. Confirm the entry with OK.
= The button is now displayed with the desired function and name in the Home menu.

7.3.2 Configuring the Dim buttons

The Dim buttons can only be configured in the Basic application. Depending on the settings, it is 
either possible to dim all operating devices or just the activated groups with these buttons.

– The Layout tab is open in the Configuration menu.

1. Activate the Dim check box. 
= The dialog box Config. button DIM is displayed.

2. In order to dim all operating devices, activate the check box Broadcast dimming.
3. To dim one or several groups, activate the respective check boxes.

= In the Home menu, the adjusted operating devices can be dimmed using the buttons.

Hint

During planning please observe, that a button can only be assigned the first 6 schedules or 
sequences that were saved.

Hint

TridonicAtco recommends activating the Dim buttons for no more than 4 groups in order to 
guarantee dimming without any time lag. 
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7.3.3 Configuring the Colour scene button

Configuration of the Colour scene buttons is suitable for applications where you want to call up 
different colour lighting situations in zones by pressing a button. 

To assign a new function to a Colour scene button, there are several possibilities for each of the 
4 zones:

Colour setting
Masking
Switching off
Fading 

– Layout for Home menu has been created.

– The Colour scene buttons are displayed in the Home menu.

1. Press the button (e.g. Colour scene1) until the dialog box with the four zones is displayed. 

=
2. To set the colour for the first zone, press the zone.

= The dialog box Details for colour event is displayed.

3. Enter the colour using one of the three tabs.
- or - 
To leave this zone unchanged, activate the check box MASK.
- or -
Press the OFF button to switch off all operating devices of this zone.

4. To switch the operating devices assigned to zone White in the colour event, activate the check 
box RGBW.

5. To set fading, press the Timing, Fading button, set the time and confirm with OK.
6. Confirm the entries with OK.

= The first zone of the colour scene is now set.
7. To set the other three zones, repeat steps 2 to 6.
8. Press the Home button.

= The Colour scene button is displayed in the Home menu with the desired lighting situation.
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7.4 Loading application-specific buttons and screen saver
In an image processing program, the design of the buttons of the Home menu can be changed to 
suit the specific application.

The bitmap template is available on the Internet (www.tridonicatco.com -> Services -> Download -
> DALI Touchpanel x-e-touchPLATTFORM).

– The check box Customized buttons is activated.

To load the application-specific graphic to x-touchBOX/PANEL via infrared, refer to "Uploading 
and downloading files", page 42.
- or -
To load the application-specific graphic to x-touchBOX/PANEL via Ethernet, refer to 
"Downloading/uploading files", page 48.

Hint

Only use the UI_Layout.bmp template (bitmap, 256 colours) and create a new design for the 
buttons and/or screen saver if you want. 
Do not change file names, sizes or file properties. 
Do not use any mobile logos.
When selecting the colours, the differences in brightness should not be too big because otherwise 
there is the danger of image persistence. If necessary, adjust the contrast in the Configuration 
menu(see "Adjusting the touchscreen", page 14).

Hint

If you want to load an application-specific screen saver, the check box in the Names tag of the 
Configuration menu must be deactivated. The new screen saver will automatically be recognized. 
If you want to create application-specific labelling for the buttons, the check box must be 
activated. The graphic UI_Layout.bmp will then be loaded.
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7.5 Manually switching a sequence, schedule or schedule list
On this page, you can operate a sequence, schedule or schedule list manually.

The following operating elements are available:

1. Press the Home button. 

 
2. Press the arrow keys as often as necessary until the Scheduler page is displayed.

3. Press the arrow key. 
= The dialog box Load is displayed.

4. Press the arrow keys as often as necessary until the desired lighting situation is displayed and 
confirm with OK

5. Press the Start button to call up the lighting situation.

Button Operating function

Opens the dialog box for selecting a lighting situation (sequence 
1 to 99, schedule 1 to 7 or schedule list).

Shows the lighting situation which is called up using the Start/
Pause, Stop and Off buttons.

Shows the status.

Start 
Calls up the lighting situation and starts the time-controlled 
sequence.

Pause 
Interrupts the lighting situation.

Stop
Ends the lighting situation (00:00:00).

Off
Switches off the lighting situation and ends the sequence.

Indicates that a time-controlled lighting situation is active. The 
button is displayed in all menus and calls up the Scheduler in the 
Home menu.

PHASED O
UT



8.1  Infrared interface Version 3.0

42

8  Interfaces x-touchBOX/PANEL

8 Interfaces

x-touchBOX and x-touchPANEL have an infrared interface which enables the transmission of:

Software updates x-touchBOX/PANEL
Configuration files (download/upload)
Application-specific graphics for the Home menu

x-touchPANEL also has an Ethernet interface which enables configuration and operation via a 
connected PC or laptop. The touchscreen and PC/laptop displays are synchronized in real time. 
Since the current statuses of several panels can be transmitted, the entire system can be operated 
with one PC or laptop. 

8.1 Infrared interface
The infrared interface is located on the right side of the bottom area of the x-touchBOX/PANEL.

1 Infrared interface

8.1.1 Uploading and downloading files 

Via the infrared interface (IrDA) you can download files to a PC/laptop or upload files from a PC/
laptop to x-touchBOX/PANEL.

To load, e.g., a software update to the x-touchBOX/PANEL, you must perform the following steps:

Determine the program version in x-touchBOX/PANEL (see "Determining the display name and 
program version", page 13).
Check if a higher version is available and download it if required. 
(http://www.tridonicatco.com -> Services -> Download -> Software -> x-touchBOX/PANEL).
Set up the infrared connection.
Install the update of the ›x-touch‹ software.

Hint

The configuration file of an x-touchBOX or x-touchPANEL contains the system settings (addresses 
of the operating devices, names of the devices, groups and scenes, etc.) and enables the 
configuration to be saved.

1

Hint

To upload an application-specific graphic for the Home menu, proceed in the same way as for the 
software update.
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– The Main Menu is displayed.

1. Press the Configuration button.
2. Press the green arrow key as often as necessary until the IrDA page (infrared devices) is 

displayed.

=
3. Activate the check box Enable discovery to enable communication with other infrared 

devices.
4. Activate the check box Enable file reception. 
5. Position the laptop and x-touchBOX/PANEL in such a way that their infrared interfaces are 

opposite to each other. They must be no more than 1 m apart and no more than 15° twisted 
against each other.

6. Prepare the PC/laptop for transmitting via infrared (see operating instructions of the 
manufacturer).
= If the conditions for receiving are met, the name of the laptop is indicated in the field  
Infrared devices. The infrared transmission symbol is displayed in the task bar of the laptop.

7. Click on the infrared transmission symbol in the task bar of the laptop. 
= A dialog box for the selection of files is displayed.

8. Select the file ›x-touchUPDATE.biz‹ and click Send.
9. Confirm with OK on the touchscreen.

= The update of the ›x-touch‹ software is saved and the system is restarted.PHASED O
UT
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8.2 Ethernet interface
To connect x-touchPANEL to a PC/laptop via Ethernet, a network cable is required. In a network, 
each x-touchPANEL must be assigned an individual IP address. If, e.g., you want to include 
several x-touchPANEL into an existing company network, consult your IT specialist for the IP 
addresses.

For networks with Firewall, Switch, etc., please also contact your IT specialist.

Network connection The following figure shows an example of how several x-touchPANEL can be integrated in one 
network.

Point-to-point
connection

If a point-to-point connection is to be established, a crossed network cable must be used.

SWITCH

x-touch PANEL

x-touch PANEL

x-touch PANEL

SWITCH

x-touch PANEL

x-touch PANEL

Ethernet CAT 5 cable (max. 100 m)

IP Address: 192.168.123.10
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1

IP Address: 192.168.123.11
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1

IP Address: 192.168.123.12
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1

IP Address: 192.168.123.13
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1

IP Address: 192.168.123.14
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1

IP Address: 192.168.123.15
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1

Crossover CAT 5 cable (max. 100 m)

x-touch PANEL

IP Address: 192.168.123.10
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1

IP Address: 192.168.123.11
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1PHASED O
UT
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8.2.1 Setting the IP address in x-touchPANEL

– The Main Menu is displayed.

1. Press the Configuration button.
2. Press the green arrow key as often as necessary until the TCP/IP tab with the IP address is 

displayed.
3. Press IP address.

= The dialog box IP picker is displayed.

4. Set the IP address with the arrow keys and confirm with OK.
5. To set Subnet Mask and Gateway, repeat steps 3 and 4.
6. Press the Main Menu symbol.

= The IP address is stored in the x-touchPANEL.

8.2.2 Setting the IP address for a network with several x-touchPANEL

For the Ethernet connection in a network, each x-touchPANEL must be assigned an individual IP 
address. The ›Network connection‹ diagram shows an example of an addressing process 
(see "Ethernet interface", page 44). The instructions below are based on this example.

1. Connect the PC/laptop and the x-touchPANEL via the network switch using network cables.
2. On the PC/laptop, the following values must be set for the NIC to which the switch for the x-

touchPANEL is connected:
IP address:192.168.123.10
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1

3. Set the following values for the first x-touchPANEL: 
IP address:192.168.123.11
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1

4. Set the following values for the second x-touchPANEL: 
IP address:192.168.123.12
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1

5. Set the following values for the third x-touchPANEL: 
IP address:192.168.123.13
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1

Hint

Please refer to the Help menu or to your operating system's manual on how to assign a permanent 
IP address.
The previous chapter explains how the IP address is set in the x-touchPANEL (see "Setting the IP 
address in x-touchPANEL", page 45).

Hint

For PCs/laptops with Firewall or other protection software, please contact your IT specialist.
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6. Increase the last digit of the IP address if you want to set additional x-touchPANEL. 255 is the 
highest possible number. 

7. Press the Main Menu button to store the IP address in the x-touchPANEL.
= x-touchPANEL can be controlled via remote control using a web browser with Java Applet 
installed. 

8.2.3 Setting the IP address for point-to-point connections

A crossed network cable is required for a point-to-point connection of an x-touchPANEL to a PC/
laptop. The ›Point-to-point connection‹ diagram shows an example of an addressing process 
(see "Ethernet interface", page 44). The instructions below are based on this example.

1. Connect x-touchPANEL with the PC/laptop using a network cable.
2. On the PC/laptop, the following values must be set for the NIC the x-touchPANEL is connected 

to:
IP address: 192.168.123.10
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1

3. Set the following values for x-touchPANEL: 
IP address:192.168.123.11
Subnet Mask: 255.255.255.0
Gateway: 192.168.123.1

4. Press the Main Menu symbol to store the IP address in the x-touchPANEL.
= x-touchPANEL can be controlled via remote control using a web browser with Java Applet 
installed. 

Hint

Please refer to the Help menu or to your operating system's manual on how to assign a permanent 
IP address.
The previous chapter explains how to set the IP address in the x-touchPANEL (see "Setting the IP 
address in x-touchPANEL", page 45).

Hint

For PCs/laptops with Firewall or other protection software, please contact your IT specialist.
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8.2.4 Establishing the connection to x-touchPANEL

Remote access of the x-touchPANEL enables operation and configuration via a standard web 
browser. You can operate almost all functions using the keyboard and mouse of your PC or 
laptop. The remote control is based on an HTML page with Java Applet. 

In order to operate x-touchPANEL on a PC/laptop the ›Java Runtime Environment‹ (JRE) must be 
installed on the PC/laptop (www.java.com). A standard web browser is used for the connection 
(e.g. ›MS Explorer‹, ›Firefox‹).

– The web browser is opened.

– ›Java Runtime Environment‹ is installed.

Enter the IP address of x-touchPANEL in the address field of the browser and confirm with the 
Enter key.

= The ›x-touch‹ software appears in the browser and can be operated and configured using 
the mouse pointer and keyboard. 

Hint

Calibration of the touchpanel must be performed with the x-touchPANEL. Do not use the web 
browser!

Hint

The link more opens the browser window for uploading and downloading configuration files and 
updates (see "Downloading/uploading files", page 48).
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8.2.5 Downloading/uploading files

Via the Ethernet interface you can download files to a PC/laptop or upload files from a PC/laptop 
to x-touchPANEL.

– The TCP/IP tab is open in the Configuration menu.

1. Click the link more...  in the browser.
= The File Up/Download window is displayed.

2. To download a configuration file from x-touchPANEL, click the link get config file.
= The dialog box File download is displayed. 

3. To upload a configuration file, firmware update or application-specific graphic for the buttons to 
an x-touchPANEL, click the Search button.

4. Open the file and click on the upload button. 
= The firmeware update, configuration file or application-specific graphic is stored in the x-
touchPANEL.

Hint

To upload an application-specific graphic for the Home menu proceed in the same way as for 
uploading a software update.

Hint

If a file has been uploaded, this must be confirmed with OK on the touchscreen of the x-
touchPANEL. 
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9 Help in the case of problems

9.1 Resetting to factory defaults
If you reset the configuration of the ›x-touch‹ software to the factory defaults, your settings and the 
addressing of the operating devices will be deleted.

– The Main Menu is displayed.

1. Press the Main Menu button.
2. Press the Configuration button.
3. Press the System tab.
4. Press the Reset to factory defaults button.

= The ›x-touch‹ software is reset to the factory defaults.

9.2 The touchscreen does not react properly
If the touchscreen does no longer react properly, it must be recalibrated.

1. Press the Main Menu button. 
2. Press the Configuration button.
3. Press the Calibrate button.
4. Touch the calibration symbol with a pen and ensure that you are touching the center of the 

calibration symbol.
 

5. Repeat step 4 twice. 
= The touchscreen is now centered.

9.3 Scenes cannot be defined

1.  Press the Main Menu button. Ensure that each device is assigned to exactly one group.
2. Press the Addressing/grouping button.
3. Press the Folder button and check the groups one after the other. Ensure that the device is 

assigned to a group.
4. Change the grouping if necessary.

The device might become damaged if the touchscreen is calibrated with the remote control 
(Ethernet connection).

Only calibrate the touchscreen on the x-touchBOX or x-touchPANEL and not via the web 
browser. 

NOTICE

Hint

To configure a scene, one operating device must only be assigned to one groupe, because 
otherwise conflicts might occur.
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9.4 Infrared connection does not work
If x-touchBOX/PANEL does not establish an infrared connection, you can reset the device (see 
also "Uploading and downloading files", page 42).

– Enable discovery is activated.

– Enable file reception is activated.

1. Press the Main Menu button. 
2. Press the Configuration button.
3. Press the IrDA tab.
4. Press the Reset button.

9.5 Ethernet connection cannot be established
Only x-touchPANEL has an Ethernet interface.

Ensure that a crossed network cable was used for a point-to-point connection (x-touchPANEL 
directly connected with PC/laptop).
Ensure that the IP address entered in x-touchPANEL and in the browser is correct "Setting the 
IP address in x-touchPANEL", page 45.
Ensure that no Firewall or protection software is disturbing the connection. If necessary, 
contact your IT specialist. 
Refresh the browser window.
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10 Technical data

x-touchBOX x-touchPANEL

Article number 24138954 24138990

Mains voltage 110-240 V AC 24/48 V DC

Mains frequency 50/60 Hz –

Power consumption 10 W 10 W

Max. output current 200 mA 2 mA

Interfaces IrDA IrDA, Ethernet

Bus system DALI 
(internal bus supply)

DALI 
(external bus supply)

Addresses for devices 64 64
2 x 64

›Basic‹
 ›Colour‹

Dimensions 
(L x W x H)

200 x 150 x 42 mm 200 x 150 x 20 mm

Permissible ambient 
temperature

0-50 °C

Weight 0,92 kg

Fastening distance (D) 155 mm

Protection type IP 20

Protection class SK I

Screen Touchpanel (5.7" / 320 x 240 pixels / 256 colors)

Overvoltage when connecting the DALI lines to the power supply for x-touchBOX.
Damage to the device. With x-touchBOX, the DALI power supply is already integrated which is not 
the case with x-touchPANEL.

 Do not connect the power supply to the DALI line of the x-touchBOX.

NOTICE
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10.1 Circuit diagram x-touchBOX

10.2 Circuit diagram x-touchPANEL

11 Disposal

In order to prevent damage to the environment: 

Dispose of the device in accordance with country-specific regulations.
The device must not be disposed of in the domestic garbage or burnt. 
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